Performance Issue

Minor Incident dashboard.peaceweb.net (Customer Dashboard) Infrastructure
6 hours, 39 minutes

Update

Resolved

This incident has been resolved.

Jan 13th, 2020 18:55 CET
Issue

Our customer dashboard is currently experiencing a performance problem. There has been a delay due to the increased number of orders. The customer dashboard is still reachable but is responding slower than usual.

For more information, please contact our support department.

+1 (877) 369-9440 / support@peaceweb.nl

Jan 13th, 2020 12:18 CET