Update from 2020-01-11 12:15 CET to 2020-01-11 13:00 CET

Scheduled Maintenance Cloud Storage
45 minutes

Update

Scheduled

Currently, we are working on our storage platform. This maintenance will be finished as soon as possible. Until then, the storage platform is not accessible.

Jan 11th, 2020 12:15 CET